Doubling, Tripling, etc imported images

Tagged: 

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #11645
    Kermit Woodall
    Participant

    I reported this problem before but I think I’ve narrowed it down now.

    QFI is reimporting images, including images from the site’s own media library, multiple times.

    This MIGHT be related to our use here of Press This! in WordPress. This used to be a core feature and is now a plugin. However, it duplicated images before and after this change.

    I think what is happening is that when a post is saved to draft the images are imported. Even if they’re already imported or came from the media library.

    I just made a post where I deliberately saved drafts four times and got four sets of images.

    #11647
    Martin Stehle
    Moderator

    PressThis uploads all the images of the new post into the library and changes the origin image paths to the new image paths, pointing to the images in the library.

    It seems on one of your site (the one which is published) the image paths could not be changed and are still pointing to an external server (wp.com). So QFIP can not find the images via their IDs or their paths in the database and uploads them again.

    Is the option to overwrite featured images at each saving activated? If yes please deactivate it and try again saving posts.

    #11740
    Kermit Woodall
    Participant

    >PressThis uploads all the images of the new post into the library and changes
    >the origin image paths to the new image path, pointing to the images in the library.

    Yes, I knew that. 🙂

    >It seems on one of your site (the one which is published) the image paths could
    >not be changed and are still pointing to an external server (wp.com). So QFIP
    >can not find the images via their IDs or their paths in the database and uploads
    >them again.

    Nope. I use your plugin on two sites. Problems I’ve described happen on both. I use Press This and it imports the image to the site itself, then your plugin imports it again. I’ve even had it with images I uploaded directly to the site and the first save will duplicate the image that was only on my site – not imported from anywhere. I’ve also had it reduplicate it when I just Save Draft up to 4 times (all I’ve tested) so far.

    If I wasn’t clear – in all cases the images definitely DID exist on my site then the plugin just duplicated them.

    >Is the option to overwrite featured images at each saving activated? If yes
    >please deactivate it and try again saving posts.

    No.

    Kermit Woodall

    #11806
    Martin Stehle
    Moderator

    I tried to reconstruct your case. I installed PressThis, used it on a news page and it worked, automatically

    • imported the image into the library once
    • set it as featured
    • changed the image URL from external to internal (i.e. changing to the image in the library)

    I tried it several times with the same results. Editing and saving the posts did not re-create any image in the library.

    In your sites the image path was not changed to internal. And that is the reason why QFIP imported the image again and again with every post saving.

    Is there any plugin which interferes with PressThis? Please try it out.

    #11818
    Kermit Woodall
    Participant

    No – on my sites the image URL was NEVER external in the examples I’ve been trying. It leaves the embedded image and then copies it to make a featured image.

    These are live sites so I can’t just turn off all plugins to test. Sorry. I did try it with all other image-related plugins turned off before I contacted you.

    So far as I can tell, without being able to turn off all plugins, you’ve got a bad bug in your plugin.

    BTW…my testing was…

    Used Press This!
    Embedded an image in the post by uploading it to the site
    Saved

    Your plugin then created another copy of the image and made it the featured image.

    #11819
    Martin Stehle
    Moderator

    Could you please describe an example of that action, e.g. with one of your sites – lets call it site A – you try to PressThis the text and image of site B. Please write out the addresses of the sites. If you do not want to publish them you can mail me at info@quickfeaturedimages.com. I will try to understand your steps.

    #11822
    Kermit Woodall
    Participant

    1. Find article I want to share.
    2. Hit Press This! (for Gadgetnutz.com or Amazfitcentral.com)
    3. Download image off of source site.
    4. Using Media Upload add the image to the article. Insert into the post.
    5. Check text/title/etc and Save or Publish post.

    Result = post with duplicated image. Like this.

    http://www.gadgetnutz.com/wp-content/uploads/2017/11/screenshot-www.gadgetnutz.com-2017-12-20-16-16-21-041.png

    Here are the images you see duplicated. I only uploaded the first one. It didn’t exist until after the article was saved as a draft or published.

    http://www.gadgetnutz.com/wp-content/uploads/2017/12/screenshot-www.magicleap.com-2017-12-20-12-39-40-151.png
    http://www.gadgetnutz.com/wp-content/uploads/2017/12/screenshot-www.magicleap.com-2017-12-20-12-39-40-151-1.png

    #11824
    Martin Stehle
    Moderator

    Ok, but I mean there is no need to download and upload the image manually. If QFIP does that why do you do it? Did I miss something?

    #11827
    Kermit Woodall
    Participant

    In some cases, there is a reason. But that wasn’t the point. I was trying to eliminate Press This as a possible cause of the problem.

    In the cases where the image IS external, there doesn’t appear to be any duplicating either.

    #11841
    Martin Stehle
    Moderator

    Ok, so as you described PressThis and QFIP work with external images. Please describe a case with internal images.

    #11846
    Kermit Woodall
    Participant

    The case I documented above IS with internal images. Look at the steps.

    #11854
    Kermit Woodall
    Participant

    Here’s the code it updated for the image in the post BTW. You can see it created the duplicate ( -1 ) image as the src image but the main image that is shown remained as the original inserted image.

    #11855
    Martin Stehle
    Moderator

    I can’t see any code.

    #11859
    Kermit Woodall
    Participant

    Ah. Well. Let me try again. Here’s another example of the code before I edited the code and removed the extra image.

    <a href="http://amazfitcentral.com/wp-content/uploads/2017/12/Cor_Cover-1270x714.jpg" rel="attachment wp-att-18892"><img class="aligncenter size-large wp-image-18892" src="http://amazfitcentral.com/wp-content/uploads/2017/12/Cor_Cover-1270x714-1.jpg" alt="" /></a>

    #11942
    Kermit Woodall
    Participant

    Any update on fixing this bug?

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.

Choose your currency:

Close
Converted prices are for reference only - all orders are charged in € Euros (€) EUR.
  • USDUS Dollars ($)
  • EUREuros (€)
  • GBPPounds Sterling (£)
  • CADCanadian Dollars ($)
  • AUDAustralian Dollars ($)
  • BRLBrazilian Real (R$)
  • INRIndian Rupee (₹)
  • CZKCzech Koruna
  • DKKDanish Krone
  • HKDHong Kong Dollar ($)
  • HUFHungarian Forint
  • ILSIsraeli Shekel (₪)
  • JPYJapanese Yen (¥)
  • MYRMalaysian Ringgits
  • MXNMexican Peso ($)
  • NZDNew Zealand Dollar ($)
  • NOKNorwegian Krone
  • PHPPhilippine Pesos
  • PLNPolish Zloty
  • SGDSingapore Dollar ($)
  • SEKSwedish Krona
  • CHFSwiss Franc
  • TWDTaiwan New Dollars
  • THBThai Baht (฿)
  • TRYTurkish Lira (₺)
  • RUBRussian Rubles