Images Not Updating As Expected

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2850
    Mark Bunner
    Participant

    I purchased Pro and have been working with it and have found a problem. I have tested this on different sites containing different themes/plugins.

    I use an autoposter which I have been wanting to make more use of; but on several types of posts, the autoposter uses a much too small graphic as the featured image. I want to use QFI to resolve that problem. The autoposter is WP Robot 4.

    Keep in mind, I’ve tested this on more than one site with differing themes and plugins; but the autoposter is the same on each site.

    Some of the autoposter posts have certain titles; some are not predefined. Some of the autoposts will contain featured images; some won’t.

    On each site I want to set pre-set featured images on the autoposts that don’t have featured images. Those are the posts with static predefined titles. The random titled posts are different topics; so they have different categories. But, these posts often have the too small featured images.

    I set a rule for “search string” and to overwrite the existing image. Then I set two rules for categories “music” and “animals”. Then, I set a rule for Post Type of “Posts”.

    Then, I tested autoposts and regular posts. If an autopost has no image, then QFI works properly and inserts and image. If an autopost has an image; and is a “category” or “post type” filter, then the first autopost featured image is replaced properly. But, any autoposts of “category” or “post type” filter after the first is not replaced. It took a lot of testing for me to figure out why some would work and some would not.

    #2852
    Martin Stehle
    Moderator

    Hello mark, thank you very much for your feedback. It seems that there is a bug with single images. Would it work for you if you would use the “multiple images” button and select only the one desired image? In the meanwhile I will look for a fix for single images.

    #2853
    Mark Bunner
    Participant

    Hi,

    I just checked the filters on two of the sites. The site which was giving me the most trouble has three filters in place:

    1. Random Images + Search String
    2. Single Image + Search String (will only get an autopost created once a month or even less.)
    3. Random Images + Category

    As suggested, I just changed the “Single Image” filter to “Random Images” and chose only the single image I want.

    Another site, which seemed to have more success with changing the image also has three filters:

    1. Random Images + Search String
    2. Random Images + Category Animals
    3. Random Images + Category Music

    You might be right. But, this site did not replace a category post image in at least one instance I know for certain.

    #2854
    Mark Bunner
    Participant

    That’s not it. I’m doing more testing.

    #2855
    Mark Bunner
    Participant

    OK……..

    It appears to be entirely related to whether there is an existing image on an autopost. It is all rule filters — not just “category” or “post type” filters as I previously thought. If an image does not exist in the autopost, then QFI fixes that with one of the chosen images I have set in the rules. If a featured image already is in the autopost, then QFI ignores it. But…. If I do anything with the post, such as changing from “Published” to “Draft”, or trashing the post, the image gets updated by QFI.

    So, QFI is checking the posts ok. But, for some reason not knowing to overwrite the image if it’s an autopost.

    #2856
    Mark Bunner
    Participant

    Now… for something REALLY INTERESTING. I thought I saw this happen earlier; but then thought I was mistaken because of doing so many tests and so many hours and tired. But, now it’s confirmed……

    When I logged in to my site and manually prompted an autopost, that autopost with an existing image was corrected by QFI with one of my preferred larger images. When I refreshed my website, the image showed correctly. So, I thought, “That one must not have a featured image; so I’ll do another.”

    I manually prompted another autopost and, as expected, the image was not replaced. But, what is REALLY INTERESTING, is that my desired image from the first autopost was now removed and it was the small image which the autoposter had orginally put in the post. My desired image was miraculously gone. Seriously. I’m not mentally unstable. Really, I’m not. 🙂

    I thought when I saw this happen in earlier testing that it was my tired mind playing tricks on me. 🙂 But, it just happened again. This time, I’m sure of it.

    #2869
    Martin Stehle
    Moderator

    Thank you very much for the testing and detailed feedback. Was the option set not to overwrite existing images?

    #2875
    Mark Bunner
    Participant

    Hi,

    It is set to automatically overwrite. And, it does overwrite if I go to the post and do anything with the post, even like clicking “quick edit” and then “update”. It is when the autopost happens that it only changes the first post created after setting the filters and then after that, they don’t change if there is a featured image already in the post.

    I haven’t figured out why the first autopost changes back to the original featured image, though.

    #2966
    Martin Stehle
    Moderator

    Good news: I fixed the bug which appears with single selected images. Tomorrow the update will be out. Your WP backend would tell you there is an update of QFIP if you activated the license.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.

Choose your currency:

Close
Converted prices are for reference only - all orders are charged in € Euros (€) EUR.
  • USDUS Dollars ($)
  • EUREuros (€)
  • GBPPounds Sterling (£)
  • CADCanadian Dollars ($)
  • AUDAustralian Dollars ($)
  • BRLBrazilian Real (R$)
  • INRIndian Rupee (₹)
  • CZKCzech Koruna
  • DKKDanish Krone
  • HKDHong Kong Dollar ($)
  • HUFHungarian Forint
  • ILSIsraeli Shekel (₪)
  • JPYJapanese Yen (¥)
  • MYRMalaysian Ringgits
  • MXNMexican Peso ($)
  • NZDNew Zealand Dollar ($)
  • NOKNorwegian Krone
  • PHPPhilippine Pesos
  • PLNPolish Zloty
  • SGDSingapore Dollar ($)
  • SEKSwedish Krona
  • CHFSwiss Franc
  • TWDTaiwan New Dollars
  • THBThai Baht (฿)
  • TRYTurkish Lira (₺)
  • RUBRussian Rubles