QFIPro deletes all after MORE tag in posts

Change 1000+ of WordPress Featured Images in 5 Minutes! Forums Questions and Answers QFIPro deletes all after MORE tag in posts

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #961
    Kelly Brady
    Participant

    Hello,
    I ran QFIPro against my test site and it removed everything after the MORE tag in posts…it left the more tag in place but removes everything after it.

    Settings used were:
    – Set first image as featured
    – Check: consider only posts without featured image
    – Check: remove first image
    – Don’t Check: Overwrite

    Is there some way to fix this, or perhaps filter out posts that have a MORE tag in them so it doesn’t damage them?

    Running WP 4.2.2 & QFIPRo 3.0.

    #970
    Martin Stehle
    Moderator

    Hello Kelly, I am very sorry you have that experience. Did you make a backup as asked in the plugin?

    Normally the remove function only considers one image (the first one). In all my tests only the first image was removed. So I could not reconstruct that the plugin removes every image in a post.

    I will look for a solution to consider the more-tag to keep images after that tag.

    #971
    Kelly Brady
    Participant

    Hi Martin – thanks for the response. I ran your plugin on a copy of my site on a separate test account, so no damage was done to my production site.

    Let me clarify a few things. The More Tag I am referring to is in posts where the “Read More” was inserted into the post manually by the author. It appears in the post as the literal text: “<!–more–>” (without the quotes).

    As I am changing themes (hence the use of your plugin), I no longer need manually inserted “Read More”‘s, so I have developed a workaround. Before running your plugin I will use the plugin “Better Search Replace” to replace the “<!–more–>” with a blank value. I except then your plugin will work for me.

    I wanted to let you know as the issue does not seem to relate to images. It seems everything after the “<!–more–>” is lost, even if it is only text and there are no images.

    Kelly

    #973
    Martin Stehle
    Moderator

    Thank you for your response, I am very glad about it.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.

Choose your currency:

Close
Converted prices are for reference only - all orders are charged in € Euros (€) EUR.
  • USDUS Dollars ($)
  • EUREuros (€)
  • GBPPounds Sterling (£)
  • CADCanadian Dollars ($)
  • AUDAustralian Dollars ($)
  • BRLBrazilian Real (R$)
  • INRIndian Rupee (₹)
  • CZKCzech Koruna
  • DKKDanish Krone
  • HKDHong Kong Dollar ($)
  • HUFHungarian Forint
  • ILSIsraeli Shekel (₪)
  • JPYJapanese Yen (¥)
  • MYRMalaysian Ringgits
  • MXNMexican Peso ($)
  • NZDNew Zealand Dollar ($)
  • NOKNorwegian Krone
  • PHPPhilippine Pesos
  • PLNPolish Zloty
  • SGDSingapore Dollar ($)
  • SEKSwedish Krona
  • CHFSwiss Franc
  • TWDTaiwan New Dollars
  • THBThai Baht (฿)
  • TRYTurkish Lira (₺)
  • RUBRussian Rubles